Making gated-impulse frequency measurements using ARTA

Charlie Laub / version 1.2 / September 2012

If you have a computer, a calibrated microphone, and a soundcard or I/O interface card you can make very
accurate quasi-anechoic frequency response measurements on your loudspeaker. In the following pages, setup
and measurements procedures using the free version of ARTA are described. ARTA is a loudspeaker
measurement program available at: http://www.fesb.hr/~mateljan/arta/index.htm

ARTA is a collection of programs for audio measurements developed by Ivo Mateljan of the Electroacoustic
Laboratory in Split, Croatia. ARTA is used for frequency response measurements, LIMP, for impedance
measurements, and STEPS, for distortion measurements using stepped sine excitation.

ARTA simultaneously generates a signal that is output from the computer to the amplifier driving the speaker
under test and captures the response of the speaker observed by the microphone. After some processing of the
mic’s response in ARTA, a very high quality measurement is obtained that is independent of the room response.
The ability to make in-home quasi-anechoic measurements on a loudspeaker for less than $200 in hardware
brings powerful measurement capabilities to the DIY speaker builder that did not exist 5-10 years ago.

SETUP AND HARDWARE:

In order to perform the gated impulse measurement successfully, you will need to elevate the speaker off of the
floor and place it away from the ceiling and walls - the greater the distance to a reflecting boundary, the better.
The orientation of the speaker (e.g. on it’s side or standing up) does not matter as long as it is away from
boundaries.

I use a Dayton Audio TSS100K tripod speaker stand to elevate the speaker under test:
http://www.parts-express.com/pe/showdetl.cfm?Partnumber=245-010

In order to make a non-marring platform for the speaker, I screwed a couple of scrap pieces of wood to the
speaker mounting plate that comes with the stand. It’s also essential to have a microphone stand. I use a round
base stand with an arm, sold by Parts-Express:
http://www.parts-express.com/pe/showdetl.cfm?Partnumber=242-045

A calibrated microphone is essential - do not waste your money on one that is not calibrated! I recommend
buying a Behringer ECM8000 with basic calibration from Cross Spectrum Labs in Springfield Mass:
http://cross-spectrum.com/measurement/calibrated_behringer.html

Another good option is the Dayton Audio EMM-6, sold by Parts-Express:
http://www.parts-express.com/pe/showdetl.cfm?Partnumber=390-801 &FTR=emm-6

In my opinion, Cross Spectrum Labs provides accurate calibration and at lower frequencies than the EMM-6,
but that doesn’t really matter unless you are trying to measure a subwoofer. For measurements over 100Hz, the
EMM-6 with calibration works well.

You will need to get the microphone’s voltage output into your computer. Both of the mics above require
phantom power, however other types may not. The mic output needs to be able to be put in to digital form, so
that requires a “sound card”. Additionally, ARTA needs to output the impulse signal to the speaker, so the
computer must have the capability to output line level signals as well. You connect the output to the amp that is
driving the speaker. Most speaker junkies have this kind of hardware available to them, so I will not get in to it
here. Other DIY hobbyists posting on forums such as Part-Express’s Tech Talk forum (http://techtalk.parts-
express.com) can give helpful advice about hardware and other parts of the measurement chain.




In-room measurement set up, using equipment described above:

This is a small room (10’ x 12”) with a 7’ ceiling. In a larger room I would position the speaker near the middle
of the room and farther above the floor if the ceiling is higher. The mic is on axis, about 30 inches away from
the speaker. This is about as close as I would position it, since you want to be away from the near-field.

I will now step through the basic procedure for making a gated impulse frequency response measurement using
a swept sine stimulus in ARTA. Sound complicated? Don’t worry, it’s easy.



When you launch ARTA, your screen will probably look something like this:
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We will start by making an impulse measurement. At the top, just below the menu, make sure that the IMP
toggle button has been selected to indicate that an impulse measurement will be made.

The impulse measurement is configured by clicking on the red “play” button (shown under the Analysis menu).
Clicking the button will open a dialog box for setting up various measurement parameters, which is shown in
the next screen shot:




We will do a swept sine impulse measurement. Select the “Sweep” tab from the dialog box as shown:
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Enter the parameters shown. Other can work too. It is useful to average 3 or more cycles of the stimulus to
reduce noise. Longer sequence lengths only serve to increase the accuracy of low frequency measurements, so
64k would be fine. The highest frequency that can be measured is one-half the sampling rate. The maximum
value that appears may depend on your soundcard’s sampling rate capabilities.

To begin the measurement, click on the Record button. This will run through the selected number of cycles of
the stimulus signal and then stop. To accept the result, click OK.

If you have successfully measured something, the ARTA impulse response window will now look something

like the following:



Example of successful impulse measurement:
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HINT: If you get what looks like broadband noise or nothing at all, it’s time to sleuth out the signal chain and
the settings for the output and input channels, check the level settings, etc. The first time you try this, it may
take a couple of iterations to get it right. It can be helpful to go back and start over using ARTA’s Spectrum
Analyzer (select the SPA button at the top) since it will send a continuous signal to the speaker.

If you get something like the above screen shot, congratulations! You have taken an impulse measurement.
Now you must do some processing on it to obtain the gated impulse frequency response. This involves setting
starting and ending markers for the impulse. These indicate the part of the captured audio signal that comes
after the first arrival of the impulse but before any subsequent reflections from nearby surfaces.

To determine where to set the markers, you will need to “blow up” the signal by increasing the gain. Use the up
arrow in the group of controls just below the word “Gain” at the right side of the screen. Increase the gain until
you see something that looks like the following:



Impulse response at high gain:
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The signal above comprises the following:

1. no signal before the initial arrival of the impulse (bracketed in )

2. the direct sound, and decay of the impulse (bracketed in green)

3. additional echoes of the direct sound, resulting from reflections off of surfaces in the room (bracketed in red,
and any part of the signal that follows) appear later.

Two markers need to be set to tell ARTA when the first (direct) impulse starts and when the echoes begin.
The first marker should be placed at the start of the direct impulse, e.g. where the green region starts in the plot

above. First, click on the appropriate location with the mouse, then click the “SET” button at the top-right
corner of the window, just below the text “Marker”. You should get something like the following:




Screen shot after the first marker has been set:
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The vertical red line at 5.85 ms is the marker we just set.

HINT: It is important to set this “begin” marker very close to the first large rise in the impulse in order to
obtain an accurate frequency response from the impulse. The position shown is pretty good, although I could
have put it a little closer.

Note that everything is in red. The color red indicates the part of the signal that is to be ignored. Since only one
marker has been set, it’s all red. We need to go ahead and set the second (end) marker to define a “gated”

region.

Set the end marker by clicking on the signal just before the first reflection. That’s it. Now the screen should
look something like this:



Screen shot showing an impulse response with begin and end markers correctly set:
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Now the portion of the signal between the markers has changed color, to black, and everything outside of the
markers is still red and will be ignored. The “end” marker is shown as a vertical yellow line.

HINT: The later that you place the “end” marker in the recorded sequence, the longer the gated sequence that
can be processed in to a frequency response, and the lower in frequency the processed FR will remain valid.
The “end” marker could have been placed just before the first large spike, but I was conservative and placed it
at a slightly earlier time point.

With the markers set, ARTA can be directed to process the data in to a frequency response. If you have
calibration for your microphone, you should upload it to ARTA at this time using the menu command “FR
Compensation” in the “Setup” menu. If you have not done this before, you must do this before processing the
gated impulse in to a frequency response.

To proceed with the calculation of frequency response, use the menu commend “Analysis > Single-gated
smoothed frequency response” as shown in the next image:




Performing an analysis of the gated impulse response to obtain frequency response:
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When you click on the menu item as shown above, ARTA will calculate the frequency response using the part
of the impulse response that you selected (in black above). A new window will open, showing the frequency

response. The next page shown an example on the small speaker that I measured as part of this tutorial.



Single gated impulse frequency response window showing result of analysis:
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Massaging the response:

The y-axis values are arbitrary, since there was no attention paid to the actual microphone output level. You can
scale the level using the “Scale Level” command in the “Edit” menu (enter the number you would like to add to
the existing data in the dialog box). After you scale the data, it may disappear (go off screen) but just click the
“FIT” button under “Top” at the top, right of the screen and the data will come back in to view automatically.
You can then play with the range to get the y-axis scale to your liking and move the response up and down
using the up / down buttons next to “Top”.

HINT: There is a yellow bar at the bottom extending from the left limit of the x-axis over to about 200Hz. This
bar indicates a region of the result that is invalid because there was insufficient data to extract the low frequency
information from the gated impulse. This is where a large room can be beneficial — by moving the speaker away
from all reflecting surfaces (including the floor) reflection will occur later and you will be able to gate off a
longer portion of the measured impulse response. In a large room in my home I can take measurements 6 feet
off of the ground and get the response to be valid down to about 100 Hz. This is probably about the lowest
practical limit for indoor measurements, however. Below this you must do a near field measurement on the
woofer alone and splice the two measurements together. See the ARTA manual for more information on this.



Now what?

So, now that you have your measurement you will want to save it. This should be in the more or less standard
format for DIY loudspeaker building, the FRD file. This will create a text file with three columns: frequency (in
Hertz), SPL in decibels, and phase in degrees.

But, before proceeding... I strongly suggest saving the minimum phase response. This is the standard used by

many crossover design programs such as PCD and ACD. ARTA will save whatever data is currently shown in
the window, however, currently there is only magnitude data shown, so we need to get the phase to display as

well.

If you have not done so before this point, open the View menu (shown in the picture below) and choose
‘Magn+Phase” to see both phase and magnitude in the plot. Subsequently, a check mark next to “Magn +
Phase” indicates this selection.

To select the minimum phase, re-open the View menu, and choose “Minimum phase”:
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Now we can save the data using the menu item “File > Export... ASCII file”
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You should be prompted to confirm that the data should be saved as an FRD file:
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Note: If you do not get this message, you likely forgot to select “Magn + Phase” in the View menu and you will
be asked to save a text (.txt) file instead of an FRD file.

Select the location where you would like to save the data file and change the file name to something related to
the driver, project, etc. before saving the file. The result is a TAB delimited minimum phase FRD file.

You have now created a minimum phase FRD data file using ARTA. Congratulations!

See, that wasn’t so hard.



