
Loudspeaker Frequency Response 
Measurement
This tutorial aims to show you how to perform a loudspeaker frequency response measurement 
using ARTA for a two-way loudspeaker system.

Required Equipment

• A sound card (either internal or external) which has two line-out (left and right channels) 
and two line-in (left and right channels).

• An amplifier (5W+ is more than ample) preferably with a line-out.

• A calibrated microphone. These are available from a number of sources but the Dayton 
Audio EMM-6 Electret Measurement Microphone appears to be the most economical and 
easy to obtain.

• A microphone pre-amplifier to amplify the signal from the microphone.

• A driver to test.

Setup

The basic setup of the equipment for a two-channel measurement is as follows:

Procedure

Step 1: Setup your Audio Device

Start ARTA and select Audio Devices from the Setup menu.
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The Audio Devices window will appear.

Select your sound card from the Soundcard driver drop down menu.

Ensure you have the correct values in the Input channels and Output channels options before 
clicking OK to close the window.



Step 2: Load the Microphone Calibration File

Select FR Compensation from the Setup menu.

The Frequency Response Compensation window will appear.

Click the Load button and use the file navigator to find the microphone calibration file. You may 
need to rename the file to have a .mic extension if it was provided with a .txt or another file 
extension.

Once you have selected the file click Open and ARTA should display the frequency response 
compensation curve in the window.

Click the Use frequency response compensation button towards the bottom of the window so that 
it stays enabled once you move the mouse away. This is actually a toggle button.



Once you load a frequency response compensation file ARTA will automatically apply this 
compensation each time the application starts so you only have do follow this process once unless 
you change microphone. You do need to keep the file in the original location as ARTA accesses it 
each time you start the application and will not apply the compensation if the file is missing.

Click OK to close the window.

Step 3: Performing the Tweeter Measurement

The first actual measurement step is to measure the tweeter.

Wire your tweeter so it is connected in phase with the correct channel of your amplifier.



Physically configure your microphone to be 1 meter away from the tweeter exactly aligned with it's
center (height from ground and side to side).

NOTE: It is important that you do not move the microphone from this position until instructed.

Select the Impulse response / Time record option from the Record menu.



The Impulse response measurement / Signal recording window will appear.

Select the Sweep tab and set the Sequence length to 64k and the Number of averages to 10.



Click on the Record button and ARTA will begin the measurement process.

Once completed the Impulse Response of your measurement will appear.

You can use the Gain buttons on the right to enlarge the signal until it is easy to see.



Because you are likely measuring inside an enclosed space we need to tell ARTA to ignore any 
sounds which has reflected from a surface within the measurement time window. This can be done 
by selecting a range where the actual measurement begins and ends.

Click the Left Mouse Button before the start of the waveform and a yellow line will appear. Any 
impulse response data prior to this point will be coloured red telling ARTA to ignore it.

Click the Right Mouse Button after the end of the waveform and prior to the first reflection and a 
red line will appear. Any impulse response data after this point will be coloured red telling ARTA to
ignore it.



In this example you can see that we are ignoring the first 6.000ms of data (288 samples) and the 
measurement window is 11.333ms (544 samples) before the first major reflection. Unfortunately the
minor reflection aroud 8-9ms is a result of the non-ideal measurement space but one which will 
have to be left in the frequency response output.

Once the gates have been set select Single-gated smoothed Frequency response / Spectrum from 
the Analysis menu.



The Smoothed frequency response window will appear and we can see the result of our tweeter 
measurement.



Select the Magn + Phase option from the View menu.

Select Minimum Phase from the View menu.



The phase data (gray line) will now show as minimum phase on the chart below the frequency 
response magnitude (green line).

This data is now ready to be exported to be used in your loudspeaker design software.

Select the ASCII file option under Export from the File menu.



Click OK to export the file as a plain .FRD file.

Name the file sensibly and move on to the next step.

Step 4 : Performing a combined Tweeter and Woofer Measurement

The benefit of using a minimum phase measurement in your loudspeaker design software is that 
you are able to utilise the full capabilities of the software with regard to calculating speaker 
interactions like comb filtering and predicting off-axis response. The downside of this is that to be 
able to utilise the minimum phase measurement we need to be able to determine the offsets of the 
speaker driver(s) relative to our reference tweeter.

Calculation in the X and Y dimensions should be easy as you have already determined where to cut 
the baffle for the speaker driver however calculation for the Z axis is trickier and it is why we take a
combined measurement of all drivers (conneted in phase) from the same location. Don't worry, it 
will all be explained in Step 6.

Note: make sure you have not moved the microphone from the position where you measured your 
initial tweeter measurement in Step 3.

Wire your tweeter and woofer so they are connected in phase with the correct channel of your 



amplifier.

Select the Impulse response / Time record option from the Record menu then click Record.



Once the measurement is complete and without changing the gated points from the tweeter 
measurement (i.e. the the measurement window remains 11.333ms) select Single-gated smoothed 
Frequency response / Spectrum from the Analysis menu.

This time, as we had the tweeter and woofer connected in phase we can see the increased frequency 



response magnitude in the 100Hz - 1000Hz range. This is to be expected as the woofer should be 
able to produce these frequencies where the tweeter naturally rolls off by this frequency.

Select the ASCII file option under Export from the File menu.

Click OK to export the file as a plain .FRD file.

Name the file sensibly and move on to the next step.

Note: You can now move the microphone location.

Step 5 : Performing a Woofer Measurement

The final step in ARTA is to measure the frequency response of your woofer(s).

Wire your woofer so it is connected in phase with the correct channel of your amplifier.

Select the Impulse response / Time record option from the Record menu then click Record.



Once the measurement is complete and without changing the gated points from the tweeter 
measurement (i.e. the the measurement window remains 11.333ms) select Single-gated smoothed 
Frequency response / Spectrum from the Analysis menu.

If you have been paying close attention you can see that at the bottom of the FR Magnitude chart 



there is a yellow line which extends from 20Hz to roughly 90Hz in the example above. This is 
effectively telling you that ARTA does not have a sufficiently long measurement window to 
accurately calculate the response of the driver in that frequency range (i.e. 20Hz - 90Hz) - or as the 
ARTA manual puts it: The horizontal bar, drawn in cursor color [yellow], denotes frequency region
where the time-bandwidth requirement is not fulfilled. This window length is set by placing the 
yellow and red markers as we did in the tweeter frequency response measurement example:

If we want to create a measurement where ARTA is able to calculate the frequency response closer 
to 20Hz then you will need to measure the raw driver response where you have a longer delay 
between the signal impulse and the first reflection. This is why manufacturers use expensive 
anechoic chambers which is not very practical for a home loudspeaker builder. A cheaper option, 
common amongst home loudspeaker builders, is to take the measurement outdoors in the open with 
the driver significantly elevated from the ground which will maximise the time before the first 
reflection reaches the microphone. It is then important to set up a sensible Number of averages in 
the Impulse response / Time record options when performing outdoor measurement to hopefully 
remove any non-continuous noise which may occur outside (e.g. a car driving past).

Unfortunately on the day I wanted to write this tutorial it was raining and so I had to do indoor 
measurements which resulted in a large 400Hz-600Hz frequency response dip evident in the 
response above.

Select the ASCII file option under Export from the File menu.

This process an be repeated for as many drivers as you wish to measure.

Step 6 : Calculating the Woofer Z Offset

In this example we will use LspCAD to show how the woofer's Z offset (or depth) can be 
determined relative to the reference tweeter by using our combined tweeter/woofer measurement. 
The LspCAD demo version will work for this and I would imagine other loudspeaker design 



software will perform this same function.

The basic theory is that as we have measured the individual drivers responses *plus *the combined 
response at a fixed point we can now load the combined response into the software as a 'reference 
measurement' and adjust the offset of the woofer until the calculated summed response of the two 
drivers aligns with the reference measurement response.

Start LspCAD and build a schematic that looks like this:

This is just dragging and dropping so should not take very long.

Click the Simulate tab at the top of the screen so as to see the Graphs window.

Whilst the Simulate tab is active we can set the driver parameters by clicking them. First click the 
top 'driver' and the Driver edit window will appear.



Within the Imported data part of the SPL data section of the form click the Browse button and 
find the tweeter .FRD file which we exported from ARTA.

Select 1/12th Octave from the Smooth drop down also located in the Imported data part of the 
form.



You can also name the driver if you wish at the top of the form.

Now click on the 'bottom' driver in the schematic to open it's Driver edit window.

Within the Imported data part of the SPL data section of the form click the Browse button and 
find the woofer .FRD file which we exported from ARTA.



Select 1/12th Octave from the Smooth drop down also located in the Imported data part of the 
form.



We have now loaded basic measurement data for both drivers into LspCAD and if you look at the 
chart we should be able to see the individual driver's responses along with a Total SPL, mag line 
which is calculated by the software.

Click the Settings option from the menu on the main form of LspCAD.

Click the SPL/Xfer tab.



In this screen we want to achieve three things, firstly, to load a 'Reference' measurement and, 
secondly, to turn off the display of the two individual drivers' responses to make it easier to read the 
chart and, finally, set the measurement distance.

Click the Browse button in the Reference section near the bottom of the form and select the 
combined tweeter and woofer .FRD file which we exported from ARTA.

In the Show part of the SPL section untick the two drivers, in this case Tweeter and Woofer. Make 
sure that Reference is ticked.

In the Measurement distance section untick the Infinite check box which should then enable the 
distance text box with a default value of 1.00m - which is, not by co-incidence, the distance we 
performed our tweeter, combined tweeter and woofer and woofer measurements from.



Close the Settings form and return to the Graphs form which should now look something like this:



In this case the orange line represents the reference measurement which we made in ARTA by 
connecting both the drivers in phase. The pink line represents the calculated summed response of 
the two drivers where LspCAD has not taken into account the physical offset of the woofer relative 
to the tweeter which is why they do not align very well.

Whilst still with Simulate mode active click on the Woofer on the schematic window and enter the 
dX and dY offset values using this image from the LspCAD manual as a guide.



Once the dX and dY values have been set configure your windows so you can see the Graphs 
window and the woofer's Driver edit window at the same time. If you click on the dZ text box you 
can then use the up and down arrows on your keyboard to vary the offset which will update the 
Graph in 'real-time' until the Total SPL, mag and Reference lines align at the higher frequencies. 
Remember that in this process everything is relative to the tweeter on-axis at 1 meter which is why 
we need to ensure the higher frequencies align.



Note: You will never get a perfect alignment due to the fact that the drivers are physically offset and
due to the effects of smoothing but you will be able to get very close.



You should now have measurements ready to load into your favourite loudspeaker design software 
with properly calculated offsets and start designing some crossovers.
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