Vaag CSD (waterval) probleem (opgelost)

... is weten!

Moderator: Beheerdersteam

Gebruikersavatar
Chris_T
Berichten: 1438
Lid geworden op: wo 30 mei 2007, 15:15
Locatie: Wageningen

Vaag CSD (waterval) probleem (opgelost)

Berichtdoor Chris_T » zo 07 sep 2014, 19:43

Hallo allemaal,

Ik ben tegen een probleem aangelopen waar ik mij totaal geen raad mee weet en ook niet op kan googlen.
Erg frustrerend, want de keuze tussen de woofers voor Project 03: 2-weg Wavecor/Vifa TL wordt o.a. daardoor bepaalt.

Om de een of andere reden zit er een 'knik' in de waterval waardoor een gedeelte van de meting voor de rest uitgeschoven is.
Alsof er een frequentieafhankelijke delay toegepast is (allpass filter?).

Om de een of andere reden schiet de curve één keer omhoog. Volle output bij 500Hz??Hoe kan dat??
Normaal gesproken zou het hele frequentieverloop, wat achter deze sprong zit, vooruit geschoven moeten worden wanneer de 1e marker voor de impuls wordt gezet.

Zie ook:
Arta_CSD_probleem.png

Arta_CSD_probleem.zip

Dit is een meting van een Seas H1499 tweeter op 70cm afstand.

CSD window settings:
FFT length: 256
FFT block shift: 1
Max. number of FFT bloks: 100
Apodizing window rise time: 0.02

Ik heb echt van alles gedaan om de oorzaak te vinden en om dingen uit te sluiten:

  • verschillende (3) mic's €250 - €5, zowel phantom als bias gevoed
  • verschillende (3) geluidskaarten/mic-preamps
  • verschillende (2) meetversterkers
  • verschillende meetafstanden (om defractie/reflecties uit te sluiten)
  • verschillende meetsignalen/samplerates
  • verschillende versies van Arta (1.7 / 1.8 / 1.82)
  • verschillende kabels

Kortom zo'n beetje alles behalve de meetsoftware,
Maar ik kan mij niet voorstellen dat het aan Arta ligt, met zoveel gebruikers moet dat allang opgevallen zijn :roll: toch?
Wie o wie weet een mogelijke oorzaak?

P.s.
Bij een loopback meting ziet alles er normaal uit.
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.
Laatst gewijzigd door Chris_T op ma 08 sep 2014, 6:08, 2 keer totaal gewijzigd.

Gebruikersavatar
pappaleo
Berichten: 6990
Lid geworden op: wo 25 sep 2013, 14:30
Locatie: verder dan Delft of Drievliet

Re: Vaag CSD (waterval) probleem

Berichtdoor pappaleo » zo 07 sep 2014, 20:37

Gebruik jij ook de laatste versie 1.8.2?

Ik heb je PIR even gedownload en er een FR van gemaakt.
Gate 6.042ms(290) Gate 4.708ms(226) net voor de reflectie op 1m55

Geeft het volgende resultaat:
ChrisFR.png

En de spectral decay:
ChrisDecay.png


Schrik niet, de vloer ligt op -40dB

Ziet er toch niet zo heel raar uit, dacht ik.
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

Gebruikersavatar
Chris_T
Berichten: 1438
Lid geworden op: wo 30 mei 2007, 15:15
Locatie: Wageningen

Re: Vaag CSD (waterval) probleem

Berichtdoor Chris_T » zo 07 sep 2014, 21:25

Met de standaard window instellingen voor CSD is het probleem wat minder zichtbaar, maar het is er nog wel :(.

Van bovenaf bekeken met een sonogram is beter te zien wat ik bedoel (CSD instellingen uit de beginpost gebruikt):
Arta_CSD_probleem_sonogram.png


<ca. 1khz duikt de curve in een keer op. Dat hoort niet.
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

b_force
Ook commercieel actief
Berichten: 12385
Lid geworden op: di 18 apr 2006, 13:27

Re: Vaag CSD (waterval) probleem

Berichtdoor b_force » zo 07 sep 2014, 21:55

Wat doet die wazige gigantische pre-ringing precies voor je impuls trouwens?

Met de "knik" bedoel je die eerste paar samples die zegmaar helemaal doorlopen?
Maar voornamelijk aan de hand van een CSD speakers uitkiezen????? :-s :think:

Gebruikersavatar
pappaleo
Berichten: 6990
Lid geworden op: wo 25 sep 2013, 14:30
Locatie: verder dan Delft of Drievliet

Re: Vaag CSD (waterval) probleem

Berichtdoor pappaleo » zo 07 sep 2014, 22:13

Het heeft te maken met je cursorpositie voor je impuls. Jij zet die op 290 en als je hem op 300 zet, zoals in de manual staat, dan is het effect er niet (veel minder).

Ik heb ook even de meting van vandaag van mijn tweeter erbij gepakt en daar loopt de impuls in 0,16ms op tot de maximale waarde. Bij jou zie je inderdaad een wat Bart pre-ringing noemt van meer dan een halve seconde. Was het wel stil in je meetruimte?
ChrisImpuls.png
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.

Gebruikersavatar
Chris_T
Berichten: 1438
Lid geworden op: wo 30 mei 2007, 15:15
Locatie: Wageningen

Re: Vaag CSD (waterval) probleem

Berichtdoor Chris_T » zo 07 sep 2014, 22:23

De pre-ringing komt door de geluidskaart, maar dat heb ik al uitgesloten als mogelijke oorzaak.
Ik heb ook metingen gedaan met andere hardware zonder deze pre-ringing, maar met idem waterval probleem.

b_force schreef:Met de "knik" bedoel je die eerste paar samples die zegmaar helemaal doorlopen?

Ik heb de beginpost even aangepast.
Aanvankelijk dacht ik dat een gedeelte van de waterval naar voren was gedrukt (in tijd).
Maar het is dus de output onderaan de in één keer uit het niets omhoog schiet.
Tweeter met 500Hz volle output? Als je de FR plot bekijkt hoort dat -15dB ten opzichte van 2kHz te zitten.
Maar voornamelijk aan de hand van een CSD speakers uitkiezen????? :-s :think:

Dat zeg ik ook niet? Maar het is ook niet relevant hier.

Edit:
Typo's
Laatst gewijzigd door Chris_T op zo 07 sep 2014, 23:40, 2 keer totaal gewijzigd.

Gebruikersavatar
MarcoSQ
Berichten: 1053
Lid geworden op: vr 21 dec 2007, 20:45
Locatie: Mijdrecht

Re: Vaag CSD (waterval) probleem

Berichtdoor MarcoSQ » zo 07 sep 2014, 22:23

(Ah, Pappaleo post tussendoor ook al iets in dezelfde richting :lol: )

Volgens mij is dit behoorlijk gerelateerd aan dat single channel-ding wat ik eerder zei.
Bart wijst je er al een beetje op :

Die rinkel vóór je eigenlijke impuls : die heb je heel vermoedelijk niet écht gemeten, maar is meer een soort rekenkundig grapje, om je impuls 'geldig' te maken.

Binnen die rinkel, zit 10% van het maximum van je piek, en dus 'start' je impuls daar in de tijd. Op sample 300, of t=0 in single channel.

Jouw linker cursor staat daar nog weer een eindje vóór. Kan ook nauwelijks anders, natuurlijk.
Maar dat betekent dus, dat die cursor in de negatieve tijd staat ;-). En ik denk dat je daar een gekkigheidje in Arta ziet : die negatieve tijd, daar weet Arta geen raad mee. En die tijdinfo, ga je wel nodig hebben met een CSD.

Zet je cursor maar zo dicht mogelijk tegen de werkelijke start van de impuls : je CSD ziet er ineens aannemelijk uit. De eerste paar tienden milliseconden zijn niet meer hetzelfde.

In dual channel zou ik die rinkel waarschijnlijk ook 'meten' (of eigenlijk : berekenen).
Maar, je zou zien dat hij niet in de akoestische output kon hebben gezeten.
In een nearfield-situatie bijvoorbeeld, zou de rinkel vóór sample 300 vallen. Dus vóórdat hij uberhaupt geluidsdruk had kunnen registreren.

(Kijk voor de gein eens naar de elektrische 'tweeter-sim'-PIRs die ik gepost had in het Single Channel topic.
Ik had daar, ter voorbereiding, exact hetzelfde geintje uitgehaald : een flinke rinkel vóór de werkelijke impuls gezet.)
Voorlopig even niet meer zelfbouwen. Komt wel weer.
Roon ROCK op een Intel NUC5i5 in een fanless doosje. HDMI out (want multichannel) -> Marantz SR1504 :rofl: -> Revel Performa3 F206 (front) en Revel Concerta M12 (rear). Twee stuks SVS SB-1000 (subs), via een MiniDSP 2x4 met DIY voedinkje in een Galaxy Maggiorato doosje.

Gebruikersavatar
Chris_T
Berichten: 1438
Lid geworden op: wo 30 mei 2007, 15:15
Locatie: Wageningen

Re: Vaag CSD (waterval) probleem

Berichtdoor Chris_T » zo 07 sep 2014, 22:53

De post's beginnen elkaar een beetje te doorkruisen. 8-[
Ik hoop dat ik niet als een ouwe zeur overkom door de commentaar steeds.
De hulp waardeer ik juist zeer.

pappaleo schreef:Het heeft te maken met je cursorpositie voor je impuls. Jij zet die op 290 en als je hem op 300 zet, zoals in de manual staat, dan is het effect er niet (veel minder).

Ja klopt, bij frequentiemetingen (single channel mode) doe ik dat ook.
Maar hier heb ik de 1e marker op 278 gezet om het probleem goed zichtbaar te maken.
Op 300 zetten kan helaas niet, dan mis je namelijk een gedeelte van de meting (het begin van de meting zit iets/ergens voor frame 300 bij een 1-kanaals meting).
Resultaat is dan dat niet alleen het probleem, maar ook een stuk van de meting wordt weggeknipt :(.
MarcoSQ schreef:(Kijk voor de gein eens naar de elektrische 'tweeter-sim'-PIRs die ik gepost had in het Single Channel topic.
Ik had daar, ter voorbereiding, exact hetzelfde geintje uitgehaald : een flinke rinkel vóór de werkelijke impuls gezet.)

Ga ik doen, dual channel is iets wat ik nog niet uitgeprobeerd heb [-o<
Laatst gewijzigd door Chris_T op di 09 sep 2014, 7:00, 2 keer totaal gewijzigd.

Gebruikersavatar
MarcoSQ
Berichten: 1053
Lid geworden op: vr 21 dec 2007, 20:45
Locatie: Mijdrecht

Re: Vaag CSD (waterval) probleem

Berichtdoor MarcoSQ » zo 07 sep 2014, 23:45

Geen probleem hoor :D !
Ik zie dat je inmiddels niet (meer) zocht naar de rarigheid in de tijd, maar naar de rare stap in amplitude. Hier rond 500Hz.

Die is ook prima te verklaren, en heeft helemaal niks te maken met single of dual channel.
Ik weet alleen niet, hoe dat eenvoudig uit te leggen...Een voorzichtige poging dan maar, met teveel vereenvoudiging:

Jij stelt een bepaalde gate in met cursor en marker. Wat de CSD doet, kun je je een beetje voorstellen als : die gate, die verplaatst ie steeds een stukje naar rechts, en toont daar een FR grafiek van, vergezeld van de tijdsverschuiving die daarbij hoort. Al die grafiekjes bij elkaar, dat is je waterval.

Al vrij snel in dat verschuiven (bij een tweeter), is ie voorbij de impuls geschoven. En dan is ie alle kennis over het highpass-gedrag van je tweeter kwijt. (Immers, die zat vooral verstopt in de lengte van de 'herkenbare lange golf' van je impuls).

Zonder kennis van het highpassgedrag, gaat ie extrapoleren wat ie wél kent. Volgens mij is dat, wat jij nu ziet. Dat extrapoleren zie je soms ook, als je de cursor overdreven ver naar links zet.
In jouw geval : zet je cursor eens voorbij 6.3ms, en maak een FR. Dat is, wat er ongeveer gebeurt.

Je kunt dit iets voorkomen door de rise time van het 'apodizing window' wat te vergroten. De vorm van de gate (ook aan de linkerzijde) wordt dan niet 'hard afkappen', maar steeds iets vloeiender. Waardoor je alsnog meer van de impuls meekrijgt. Met het nadeel idd, dat je een hoop details kwijtraakt. Ik zou dat niet doen. En zeker bij een tweeter niet zo zinvol. Bij een woofje (met veel lagere highpass!), loop je ook pas veel later in de tijd, tegen dit 'probleem' aan.
Voorlopig even niet meer zelfbouwen. Komt wel weer.
Roon ROCK op een Intel NUC5i5 in een fanless doosje. HDMI out (want multichannel) -> Marantz SR1504 :rofl: -> Revel Performa3 F206 (front) en Revel Concerta M12 (rear). Twee stuks SVS SB-1000 (subs), via een MiniDSP 2x4 met DIY voedinkje in een Galaxy Maggiorato doosje.

Gebruikersavatar
Chris_T
Berichten: 1438
Lid geworden op: wo 30 mei 2007, 15:15
Locatie: Wageningen

Re: Vaag CSD (waterval) probleem (opgelost)

Berichtdoor Chris_T » ma 08 sep 2014, 6:08

Bedankt!
Het begint mij nu een stuk duidelijker te worden wat er aan de hand is.
Ik zie het ook terug in metingen van HH en K+T.
Het is mij eigenlijk nooit opgevallen.

Maar gek dat ze er dan geen correctie voor implementeren, kan toch niet zo lastig zijn?
Het highpass gedrag van de tweeter is al bekend bij de 1e 'dia' zegmaar.
Dan hoeft er enkel een soort FR-compensatie op los gelaten te worden voor dia's na de impulspiek.

Hoe dan ook ik ben blij dat de oorzaak nu gevonden is, weer wat geleerd. :D

P.s. Raar dat zoiets niet in de handleiding van Arta wordt vermeld, ik zal niet de eerste zijn die hier tegenaan gelopen is.
En te bedenken dat ik van plan was om de beste man hierover te mailen, wat dus een 'beginners denkfout' blijkt te zijn.

b_force
Ook commercieel actief
Berichten: 12385
Lid geworden op: di 18 apr 2006, 13:27

Re: Vaag CSD (waterval) probleem (opgelost)

Berichtdoor b_force » ma 08 sep 2014, 12:13

Het is lang geleden dat ik in de wiskundige theorie ben gedoken over deze dingen, maar als ik me het goed herinner is het een beetje inherent aan het principe.
Als je dat wilt corrigeren, ga je compromissen maken en zul je dus een bepaalde situatie van te voren moeten inschatten.
De vraag is of je dat wilt.

Overigens zijn er wel meer "gekke" dingen in ARTA.
Zo snap ik bv niet dat de THD grafiek (F12) enkel in dB's wordt weergegeven en niet relatief.
Absolute vervorming is namelijk zo goed als onmogelijk te vergelijken (vertekend namelijk ontzettend)

Gebruikersavatar
MarcoSQ
Berichten: 1053
Lid geworden op: vr 21 dec 2007, 20:45
Locatie: Mijdrecht

Re: Vaag CSD (waterval) probleem (opgelost)

Berichtdoor MarcoSQ » ma 08 sep 2014, 19:18

Ik denk dat je Mateljan heel blij maakt, als je hem hier een oplossing voor kan aanreiken :lol: .
Volgens mij kan dat niet; zou het 'verzinnen' van informatie zijn, waar die niet aanwezig is. De wiskundige kant heb ik ook zeker niet paraat, hoor :oops: :lol: .

(Of je moest een flinke linkwitz transform op je tweetie willen zetten om een CSD'tje te maken. Zal ongetwijfeld werken, maar of dat nou zo handig is.... :lol: :rofl: )

Er staat al 'opgelost' achter, maar toch een kleine toevoeging die ik vergat.
Ik zie dat je blijkbaar ongeveer 2,5 ms wilt 'zien'.

In dual channel zou je dan de linker cursor, minimaal ongeveer 2,5ms 'vroeger' dan normaal zetten.
Dan kan je gate dus niet voorbij de impuls geschoven worden, binnen de tijd die je wilt zien. Werkt prima, mits de impuls natuurlijk mooi schoon is in die tijd.

Je zou dat ook kunnen proberen in single channel; maar ik vermoed dat je dan weer in het negatieve-tijd-geneuzel van mijn 1e post, terecht komt...allemaal dezelfde grafiekjes.
Voorlopig even niet meer zelfbouwen. Komt wel weer.
Roon ROCK op een Intel NUC5i5 in een fanless doosje. HDMI out (want multichannel) -> Marantz SR1504 :rofl: -> Revel Performa3 F206 (front) en Revel Concerta M12 (rear). Twee stuks SVS SB-1000 (subs), via een MiniDSP 2x4 met DIY voedinkje in een Galaxy Maggiorato doosje.

Gebruikersavatar
MarcoSQ
Berichten: 1053
Lid geworden op: vr 21 dec 2007, 20:45
Locatie: Mijdrecht

Re: Vaag CSD (waterval) probleem (opgelost)

Berichtdoor MarcoSQ » ma 08 sep 2014, 19:39

Bijgaand nog twee plaatjes, misschien duidelijker.
Is een elektrische sim die hier nog slingert; een 2e orde highpass op 1500Hz. Zou verder geen heel vreemd resonant gedrag moeten vertonen.

Eerst de cursor op de normale plek :
2014-09-08 19_26_28-Cumulative Spectral Decay (dual channel - simulated tweeter - 2nd order LR high - cursor vlak voor start impuls.png
Dat lijkt op wat jij ziet. Al na pak 'm beet 0,8ms komt het 'laag' ineens omhoog.

Dan de cursor 3.2ms vroeger in de tijd gezet :
2014-09-08 19_23_39-Cumulative Spectral Decay (dual channel - simulated tweeter - 2nd order LR high - cursor 3.2ms naar links verplaatst.png
Ook het laag 'klopt' nu weer.
Je hebt niet voldoende permissies om de bijlagen van dit bericht te bekijken.
Voorlopig even niet meer zelfbouwen. Komt wel weer.
Roon ROCK op een Intel NUC5i5 in een fanless doosje. HDMI out (want multichannel) -> Marantz SR1504 :rofl: -> Revel Performa3 F206 (front) en Revel Concerta M12 (rear). Twee stuks SVS SB-1000 (subs), via een MiniDSP 2x4 met DIY voedinkje in een Galaxy Maggiorato doosje.


Terug naar “Meten....”

Wie is er online

Gebruikers op dit forum: CCBot en 1 gast